Skip to content

Release Notes

Version 1.0.0

08 June, 2022

  • Initial release

Version 1.0.1

28 June, 2022

  • Fix minor issues
  • Update dependencies

Version 1.1.0

22 July, 2022

  • Append laravel implementation
  • Fix minor issues
  • Update dependencies

Version 1.2.0

30 August, 2022

  • Add RTL layouts
  • Change JS folder Structure
  • Update Iodine (Form Validation) API
  • Update Tom Select, Filepond, QuillJS, Flatpickr Usage
  • Update dependencies

Version 1.2.1

13 September, 2022

  • Automatic select the active link navigation
  • Fix minor issues v1.2.0

Version 1.3.0

7 October, 2022

  • Append Vanilla JS version (No frameworks)
  • More Grid.js table examples

Version 1.3.1

10 October, 2022

  • Update dependencies
  • Fix minor issues

Version 1.3.2

6 November, 2022

  • Replace "Support" plugin to Tailwind CSS v3.2 support variant
  • Update dependencies

Version 1.4.0

11 December, 2022

Version 1.4.1

04 January, 2023

Version 1.5.0

15 February, 2023

  • ES6 RTL Layout
  • Update dependencies

Version 1.5.1

17 March, 2023

  • Upgrade to Laravel 10
  • Update dependencies

Version 1.5.2

20 April, 2023

  • Upgrade to Tailwind v3.3.1.
  • Remove the @tailwindcss/line-clamp plugin.
  • Fix the carousel lazy loading issue.
  • Update the dependencies.
  • Improve ES6 components

Version 1.5.3

15 June, 2023

  • Fix Minor Issues & Update Dependencies

Version 1.5.4

11 July, 2023

  • Refactor Popper & Tooltip component.
  • Update the dependencies.

Version 1.5.5

07 Septempber, 2023

  • Update Documentation
  • Add Livewire 3 Guide
  • Update the dependencies.

Version 1.6.0

02 November, 2023

Version 1.6.1

04 January, 2024

  • Replace w-_ h-_ to size-*
  • Upgrade to Tailwind CSS v3.4
  • Update the dependencies.

Version 1.7.0

01 March, 2024

  • Refactor components
  • Fix dropdown and popover issue in AlpineJS, Livewire 3.4.6 and higher versions
  • Update the dependencies.

WARNING

If you are using the Laravel, Livewire, or AlpineJS edition, you may have encountered an issue with the dropdown or popover component in Livewire 3.4.6 and higher versions. To fix this, you should download the latest version of the lineone theme and replace the following files:

resources/js/store.js
resources/js/utils/breakpoints.js
resources/js/components/usePopper.js

Version 2.0.0

10 May, 2024

  • Upgrade to Laravel 11
  • New AI Chat Page
  • Fix minor issues
  • Update dependencies

WARNING

QuillJS has a new version available! If you're using an older theme version and encountering compilation issues in your app.js (or js/libs/forms.js for ES6) file, here's how to update your import statement:

js
import Quill from "quill/dist/quill.min"; // @see https://quilljs.com/
import Quill from "quill"; // @see https://quilljs.com/